Re: [Emerald] Failed 2.5 Upgrade

Dale E. Reed Jr. ( (no email) )
Fri, 18 Dec 1998 08:18:14 -0800

David Mulberry wrote:
> I decided to go ahead and try RC3 of 2.5, now I wish I had waited a little
> longer. I followed the recommendations for creating a second database call
> Emerald25 and copied the Emerald database into it (I don't have a second SQL
> server so these databases are on the same machine) . I ran the update
> scripts (ran the database upgrade from Emerald Admin)on the Emerald25
> database and then tried to connect to the db with a 2.5 client.
> I get all kinds of errors related to tables being empty....
> Groups Code table
> Regions Code table
> Account Types etc etc....

This is a known issues that has been posted quite a bit here.
Go into the Emerald admin, General, Billing Groups and set the
global option for each group on.

> This wouldn't bother me to much but now when I go into my Emerald 2.1 client
> (connecting to the original Emerald db) and try to access an account I get
> "Pay Period Not Found" and then a "13:Type mismatch"

Did you just copy your original DB or did your update or change
anything the original? I'm not sure why testing 2.5 would cause a
problem on your original database, unless you accidently ran the
update on the 2.1 DB, it should not have changed. Go into the
Emerald 2.1 admin and make sure your pay periods are in tact. It
sounds like something changed them.

-- Dale E. Reed Jr.  (       IEA Software, Inc.      |  RadiusNT, Emerald, and NT FAQs Internet Solutions for Today  |

For more information about this list, including removal,please see