Mail System Error - Returned Mail

Mail Administrato ( )
Wed, 16 Sep 1998 10:49:22 +0200

--===========================_ _= 3650207(81)
Content-Type: text/plain

This Message was undeliverable due to the following reason:

Your message was not delivered because the destination computer was
not reachable within the allowed queue period. The amount of time
a message is queued before it is returned depends on local configura-
tion parameters.

Most likely there is a network problem that prevented delivery, but
it is also possible that the computer is turned off, or does not
have a mail system running right now.

The queue containing messages destined for
was expired by the Postmaster of

The following recipients did not receive your message:


Please reply to
if you feel this message to be in error.

--===========================_ _= 3650207(81)
Content-Type: message/rfc822

Received: from ([])
by (Post.Office MTA v3.1 release PO205e
ID# 127-49346U1000L100S0) with ESMTP id AAA168
for <> Sat, 12 Sep 1998 17:20:05 +0200
Received: from ( []) by (NTMail 4.00.0020/NT6651.00.c89adb95) with ESMTP id za000511 for <> Sat, 12 Sep 1998 08:02:03 +0100
Received: from [] by (NTMail 4.00.0020/NT6651.00.c89adb95) with ESMTP id jifaaaaa for <> Sat, 12 Sep 1998 08:02:00 +0100
Received: from (unverified []) by
(Rockliffe SMTPRA 2.1.5) with SMTP id <> for <>
Sat, 12 Sep 1998 08:12:29 -0700
Received: from ( []) by (NTMail 3.03.0016/1.agp1) with ESMTP id va351151 for <> Sat, 12 Sep 1998 08:06:54 -0700
Received: by with Internet Mail Service (5.5.2120.0)
id <RH3K9YBH> Sat, 12 Sep 1998 11:06:07 -0400
Message-ID: <>
From: "George G. Stossel" <STOSSEL@DACOR.COM>
To: 'Windows NT ISP Mailing List' <>,
'MS Exchange List' <>
Subject: MAPISEND called from Perl Program
Date: Sat, 12 Sep 1998 11:05:58 -0400
MIME-Version: 1.0
X-Mailer: Internet Mail Service (5.5.2120.0)
Content-Type: text/plain

I am trying to call mapisend (sendmail) from a Perl 5.003 program.

I have the Exchange server (5.5) profile set up so that I can execute
mapisend from an MS-DOS prompt and it works fine.

I can call mapisend from a Perl program using the system() function and
when I run the Perl program from the MS-DOS prompt it works fine.

If I call the Perl program from an HTML page served up by IIS 4.0 I get
a mapisend error "Mapi Logon Failed: 3". This is the same error I see
if the Exchange profile is not set up for the user mailbox.

Any ideas for solving or debugging the problem would be appreciated. If
anyone has an alternate method for sending mail from a Perl CGI script
would also be appreciated.


George G. Stossel, President Phone:
DACOR, Inc. FAX: 419.353.0149
519 W. Wooster Street Sales: 800.447.5333
Bowling Green, OH 43402-2763 03 USA Email:

--===========================_ _= 3650207(81)--