[RadiusNT] problem with ports

Jim Whaley ( (no email) )
Fri, 19 Nov 1999 12:40:22 -0500

I have a BIG problem! (doesn't everyone who writes here?)...

I'm running RadiusNT 2.5.175 on NT4.0, SQL 7.0.

Until today, I have had a bunch of Ascend Maxs. For each max, I had a
server entry in the servers table, and the corresponding ports in the
serverports table.

Concurrency works great, and I can easily tell who's online at any given
moment, etc.

We got bought by a telco that has Ascend TNTs which talk to a machine
running "Access Registrar" (AR) from Cisco. By combining the TNTs and AR
together, our company has a product they call "Port Manager". It allows us
to set aside a certain number of ports (we have 400) for ISP type customers.
It uses the last 4 digits of a phone number (6705 in our case)..When it sees
a call to 6705 it redirects the radius requests to my radiusnt server for
auth/acct. It DOES auth/acct OK.

The problem is that the Access registrar machine's IP is a xxx.xxx.xxx.15
The TNT's are xxx.xxx.xxx.21 and xxx.xxx.xxx.22.

I have to point MY radiusNT at .15 ... The accounting records say .21!

Because of this, I'm not sure how I can deal with the servers/serverports

I can't put the tnts in to servers/serverports directly because I would then
be bypassing portmanager.

Has anyone else run up against this sort of situation before? Is there ANY
way I can work around it? I'm kinda bummed that I can't do concurrency.


Jim Whaley

For more information about this list (including removal) go to: