RE: [Emerald] 2ND Request for HELP - USER AUTHENTIFICATION PROBLEMS

Robert H. Clugston ( (no email) )
Fri, 26 Mar 1999 12:34:52 -0800

David,
Did you run the database upgrade?

-----Original Message-----
From: emerald-request@iea-software.com
[mailto:emerald-request@iea-software.com] On Behalf Of David W. Kornitz
Sent: Thursday, March 25, 1999 6:28 PM
To: 'radiusnt@iea-software.com'; 'emerald@iea-software.com'
Subject: [Emerald] 2ND Request for HELP - USER AUTHENTIFICATION PROBLEMS

We have recently upgraded to Emerald 2.5. Since doing so, we
started noticing users having more problems getting authenticated.
Running Radius in debug mode, the following occurs: (Username and
Password have been change.)

------------------------------------------------------------------

radrecv: Request from host cc5fc483 code=1, id=165, length=60
NAS-Identifier = 127.0.0.1
NAS-Port = 0
User-Name = "USERX"
Password = "[\300Rmz\373\320\264\236\305o3\337\336\376["
rad_authenticate_ODBC() Password =
"[\300Rmz\373\320\264\236\305o3\337\336\376["

SQL Statement: Select DateDiff(Minute, GetDate(), DateAdd(Day,
(ma.Extension+ma.OverDue+1), maExpireDate)), DateDiff(Minute, GetDate(),
DateAdd(Day, sa.Extension+1, saExpireDate)), sa.AccountID, sa.AccountType,
sa.Password, sa.Login, sa.Shell, ma.Balance, ma.OverLimit From
MasterAccounts ma, SubAccounts sa Where (sa.Login='USERX' or
sa.Shell='USERX' or sa.Email='USERX') AND ma.CustomerID=sa.CustomerID and
sa.Active<>0 and ma.Active<>0

Decrypted Password: PASSWORDX
Database Password: WINNT\
==============================================
(WINNT) User:_ Domain: Password:PASSWORDX
==============================================
Sending Reject of id 165 to cc5fc483 (lasagna.compufort.com)
SQL Statement: INSERT INTO RadLogs(RadLogMsgID, LogDate, Username, Data,
CallerID) VALUES (11, GetDate(), 'USERX', 'PASSWORDX', NULL)

User: USERX Bad Password

----------------------------------------------------------------------------
-----------------------

Each time the attempt fails (provided the password is correctly entered) on
the line:

==============================================
(WINNT) User:_ Domain: Password:PASSWORDX
==============================================

the username is not correct. In this particular example, it is
not intelligible and in other cases you'll see "NAS-PORT", "User-Name"
or something similar. The problem occurs on both from "RADLOGIN", as
well as, the two TOTAL CONTROL racks.

To eliminate the server as the source of the problem, we installed
EMERALD 2.5 with RADIUS on a new machine (fresh install) and the same
problem reoccurred.

The problem is not constant, after three or four failed attempts it
just starts working again and then stops again.

>Additional Info:
>
> Microsoft IAS Service Correctly Authenticates the users with
> RADLOGIN and the two USR/3COM Racks
>

Any suggestions would be greatly appreciated.

David Kornitz
Compufort

For more information about this list, including removal,
please see http://www.iea-software.com/maillist.html

For more information about this list, including removal,
please see http://www.iea-software.com/maillist.html