Re: Emerald Problem

Dale E. Reed Jr. ( (no email) )
Sun, 20 Sep 1998 22:18:25 -0700

Josh Hillman wrote:
> > From: Dale E. Reed Jr. <>
> > You need to go into the Emerald Admin, Config Radius and add a set of
> > DEFUALT attributes for the new service you created. If a service does
> > not
> > have a default set of attributes, users will not be authenticated for
> > that
> > service.
> I just realized that Emerald Admin 2.1.0, if any changes are made to
> existing Radius Defaults (and maybe adding new ones?) apparently after
> running rad25_up.sql, Emerald Admin will choke when trying to update the
> RadAtConfigs table. I had this happen to me tonight simply because I
> wanted to change the "Ascend-Maximum-Time" value from 42300 to 28800.
> Unfortunately, it not only failed to make the change, but also wiped out
> all rows in the table that had anything to do with "PPP". So at this
> point, no one with that AccountType could log in ("No Attributes").
> Emerald Admin could not re-enter the RadAtConfig values.
> After sifting through the data for other accounttypes that we use, I
> managed to recreate the entries for "PPP" manually; people were then able
> to dial up again.
> Is there an Emerald Administrator that works correctly after running
> "rad25_up.sql" (for use with RadiusNT 2.5.124)?
> Emerald 2.1.11, RadiusNT 2.5.124, MSSQL Server 6.5 SP3, NT4 (intel) SP3

Yes. This has been brought up several times here. The Emerald 2.2
admin will work correctly after the script is applied.

-- Dale E. Reed Jr.  (       IEA Software, Inc.      |  RadiusNT, Emerald, and NT FAQs Internet Solutions for Today  |