Re: radius does not authenticate.

Dale E. Reed Jr. ( (no email) )
Sat, 05 Sep 1998 14:30:27 -0700

Franco Nogarin - Cascade Publishing wrote:
> I am running emerald with RadiusNT 2.5.107 and SQL 6.5
> when the server reboots radius does not authenticate.
> I have to restart the radius service after a reboot.
> I tried setting the registry entry to use the Depend On Service, but the
> problem still occurs,
> Could someone tell me the correct registry entry or suggest an alternative?

Its not as simple as a registry setting. You see, when SQL Server
starts, it marks all databases as suspect until it verifies them.
So when RadiusNT starts and connects, the only database it gets
is the master database. Its even more enjoyable, because once it
allows the database to be the "current" one, it may still not make
all of the objects in the table available. This is all assuming that
there were not any problems. If so, the database/objects might not
be available for a long time. :(

So what we did is a fairly radical ming change on how RadiusNT
starts up that will cause it to loop endlessly waiting for
SQL Server and all the required objects to become available.
The downside of this is that if you try and run RadiusNT against
a database that isn't setup right, it will just loop and not tell
you what the real problem is.

You can try the beta 2.5.134 beta from the following directory which
should solve your problem. Please realize that it *IS* a beta and
should be treatedd as such (this means TEST IT, don't just through
it into production and hope that you don't run into any problems).

The URL is:

(yes, the beta directory is hidden....)

-- Dale E. Reed Jr.  (       IEA Software, Inc.      |  RadiusNT, Emerald, and NT FAQs Internet Solutions for Today  |