Re: Y2K and Radius: maExpireDate above 12-31-1999 (year 2000)

Dale E. Reed Jr. ( (no email) )
Fri, 24 Jul 1998 16:42:45 -0700

Mike Miller wrote:
> Radius 2.2 is y2k compliant. In our testing yesterday we were using a date
> of 1-1-2050 (randomly picked.. no special reason). I tried the test again
> today, except this time with a date of 1-1-2010. It appears RadiusNT 2.2
> will handle 2010 completely fine. I doubt RadiusNT 2.2 will ever use a
> date larger than 2010 (like 2050), unless of course by some wierd miracle a
> customer decides to pay 50 years Internet access in advance (yeah right!).
> I am content with a successful test.

I'm guessing the issue resolves around the year 2017 (If I remember
RadiusNT 2.5 should be able to handle the years higher than 2017. 2.2
(which parses the dates) may have problems with it.

-- Dale E. Reed Jr.  (       IEA Software, Inc.      |  RadiusNT, Emerald, and NT FAQs Internet Solutions for Today  |