emerald and radius

BA ( iml@interconnect.net )
Sat, 14 Jun 1997 18:40:20 -0500

well I have been trying to get this thing running for a while with no

figured I could get some help here

we are currently running radiusNT .60 with no problems on an Access DB,
just got SQL up and am trying to get the whole emerald package
going....however, I can't authenticate a user....also I get quite a few SQL
errors on startup...here is the debug info and help would be appreciated.

---D:\radius>radius -x15 -o

0) EncryptPasswords: 01) IgnoreCase: 12) AuthPort: 16453) ReqAcctAuth: 04) AcctPort: 16465) Mode: 16) Options: 1017) Debug: 158) ODBCDatasource: LocalServer9) DataDirectory: d:\mssql\data10) AcctDirectory: d:\mssql\data11) UsersFile: Users12) Username:13) Password:

Param: Debug Level: 15Param: ODBC Only EnabledInitializing Winsock...ODBC Datasource: 'LocalServer'...Allocating ODBC Henv...Allocating ODBC Connect...Making ODBC Connection...Allocating Statement...

SQL Statement: Select Name, RadAttributeID, Type From RadAttributes

ODBC: SQLExecDirect Error: [Microsoft][ODBC SQL Server Driver][SQL Server]Invalid object name'RadAttribues'.

SQL Statement: Select ra.Name, rv.Name, rv.Value From RadValues rv,RadAttribues ra Where rv.RadAttributeID = ra.RadAttributeId

ODBC: SQLExecDirect Error: [Microsoft][ODBC SQL Server Driver][SQL Server]Invalid object name'RadValues'

odbc_read_client_info()Allocating Statement...

SQL Statement: Select Server, IPAddress, Secret From Servers

ODBC: SQLExecDirect Error: [Microsoft][ODBC SQL Server Driver][SQL Server]Invalid object name 'Servers'.Allocating Statement...config_init(): dict_valfind(Lifetime-In-Days) not found.

Radius NT is ready to receive requests!radrecv: Request from host cef2c90f code=1, id=1, length=0Received unknown attribute 4Received unknown attribute 5Received unknown attribute 1Received unknown attribute 2rad_authenticate_ODBC()LOG: Authenticate: from radac.interconnect.net - No User Name

Response Time: 20

-----from radlogin

D:\radius>radlogin test testuser

Checking Radius user test:(null): couldn't open /radius/server to find servers^C